Reminder: 2021-22 Secure Browser Must Be Installed on Desktop Devices by August 31, 2021
Back Informational  |  Action Required

Reminder: 2021-22 Secure Browser Must Be Installed on Desktop Devices by August 31, 2021

Aug 13, 2021

All devices running Windows, MacOS, and Linux operating systems will need to be updated to the latest version of the Secure Browser by Tuesday, August 31, 2021. After August 31, any older versions of the desktop Secure Browser will not be supported for ELPS and ELPT tests.

If you have any questions, please contact the Louisiana ELPT Help Desk for assistance.

Topics:
  • ELPS
  • ELPT
  • Preparing for Testing
  • Testing Tools and Resource
  • Technology
  • English